Комплекс средств НИС

Руководство администратора

Административная панель разработчика

Описание входа в аккаунт

 

Для выполнения входа в аккаунт (Рисунок 1) необходимо в соответствующих полях ввести логин и пароль, а также выбрать из раскрывающегося списка раздел (Пространство), в который будет выполнен вход:

  • Development (Пространство разработчика);
  • Marketing (Пространство маркетинга — аналитика поведения посетителей и канал гео-контекстной рекламы);
  • Profile (раздел редактирования Профайла).

Логин должен быть введён в формате e-mail адреса, с ограничением по длине в 254 символа.

Рисунок 1. Вход в аккаунт

 

Описание окна регистрации аккаунта

Меню заголовка

Пункты меню в заголовке административной панели

 

В заголовке административной панели представлены следующие пункты меню:

  • Меню Приложений (создание нового/редактирование приложений);
  • Меню учетной записи (Профайла) и Пространств;
  • Помощь ().

 

 

Переключение Приложений

 

Для переключения между одним из существующих или для создания нового Приложения необходимо выбрать соответствующий пункт из раскрывающегося списка (Рисунок 2).

 

Рисунок 2. Раскрывающийся список для работы с Приложениями

Переключение Пространств

Для входа в меню текущего Профайла, а также для переключения Пространств необходимо выбрать соответствующий пункт из раскрывающегося списка (Рисунок 3).

Рисунок 3. Раскрывающийся список для работы с Профайла и Пространствами

Личное пространство

Редактирование личной информации Разработчика

Для того, чтоб открыть диалог редактирования Профайла, необходимо нажать на кнопку редактирования () в окне информации о Профайле (Рисунок 4).

Рисунок 4. Окно информации о текущем Профайле

 

Также диалог редактирования Профайла можно вызвать с помощью кнопки редактирования Профайла () в панели основного меню (Рисунок 5).

Рисунок 5. Подменю работы с Профайлом

Диалог редактирования Профайла

Диалог редактирования Профайла состоит из трёх подразделов:

  • Редактирование основной информации (Рисунок 6). В данном подразделе можно редактировать фамилию, имя, пол, дату рождения и компанию владельца Профайла.

Рисунок 6. Редактирование основной информации Профайла

 

  • Редактирование адреса (Рисунок 7). В данном подразделе можно редактировать страну, регион (область/край), город, индекс и непосредственно адрес владельца Профайла.

 

Рисунок 7. Редактирование адресной информации Профайла

 

  • Изменение пароля (Рисунок 8). В данном подразделе для смены пароля необходимо ввести старый пароль, а затем ввести и подтвердить новый пароль.

Рисунок 8. Редактирование пароля Профайла

Раздел трансфера Приложения другому Разработчику

Для трансфера Приложения другому Разработчику необходимо нажать на соответствующую кнопку () в подменю работы с Профайлом (Рисунок 5). В появившемся окне (Рисунок 9) необходимо нажать на кнопку .

Рисунок 9. Трансфер Приложения другому Пользователю

 

Затем в появившемся окне (Рисунок 10) необходимо выбрать Приложение для трансфера из раскрывающегося меню, затем ввести идентификатор Пользователя (User UID), которому будет осуществлён трансфер. После ввода данных необходимо нажать на кнопку .

Рисунок 10. Трансфер Приложения другому Пользователю

Пространство разработчика

Данное пространство предназначено для создания и настройки мобильных Приложений, карт, разграничения доступа пользователям. Также включает в себя аналитические и маркетинговые инструменты. Основной функционал:

  • Конструктор мобильных приложений с web интерфейсом;
  • Создание карты здания, отрисовка и добавление помещений, наполнение контентом базы данных (описания и изображения);
  • Создание маршрутов, отрисовка графов маршрутов и их назначение;
  • Привязка маяков к карте здания, создание базы данных маячков и их мониторинг, привязка маячков к зонам;
  • Привязка маяков к карте здания, создание базы данных маячков и их мониторинг, привязка маячков к зонам.

 

Создание нового/выбор существующего Приложения

Для создания нового или выбора существующего Приложения необходимо выбрать соответствующий пункт подменю в разделе работы с Приложениям (Рисунок 11).

Рисунок 11. Меню работы с Приложениями

 

Для создания нового Приложения необходимо нажать на кнопку «Create application» в раскрывающемся списке, после чего появится окно создания Приложения (Рисунок 12).

Рисунок 12. Создание нового Приложения

 

Для создания нового Приложения необходимо указать следующие данные:

  • Имя Приложения (Name);
  • Описание Приложения (Description);
  • Сертификаты APNS (Apple Push Notification Service). Описание генерирования и загрузки данных сертификатов описано в пункте 1.5.1.1 данного Руководства. При создании нового Приложения необходимо указать следующие сертификаты:
    • APNS Development — сертификат APNS для стадии разработки, отладки и тестирования;
    • APNS Production — сертификат APNS для непосредственного размещения Приложения в AppStore;

Допустимо использование одного сертификата APNS как для стадии Development, так и для стадии Production. Если используется только один сертификат, то в полях APNS Development и APNS Production указывается один и тот же путь к сертификату.

  • GCM (Google cloud messaging)
    • GCM API Key — ключ для аутентификации приложения в GCM;
    • GCM Sender ID — идентификатор приложения для CGM.
  • Budle IDs:
    • Apple Bundle ID — уникальный идентификатор приложения в AppStore;
    • Google Bundle ID — уникальный идентификатор приложения в PlayMarket.

 

Генерирование и загрузка сертификатов для серверов пуш-уведомлений Apple

Для того, чтобы сгенерировать и загрузить сертификаты для серверов Пуш-уведомлений необходимо быть участником Apple Developer Program и иметь Apple ID. Для каждого Приложения, в котором будет интегрирован механизм push-уведомлений, необходимо создать новый Apple ID и Provisioning Profile, а также SSL-сертификат для сервера. Эти действия выполняются на iOS Provisioning Portal. Для генерирования и загрузки сертификатов для серверов пуш-уведомлений Apple необходимо выполнить следующие шаги:

  • Войти в свой аккаунт в Apple Developer Portal (Рисунок 13).

Рисунок 13. Вход в аккаунт в Apple Developer Portal

 

  • Выбрать вкладку Certificates, IDs & Profiles (Рисунок 14).

Рисунок 14. Основное меню в Apple Developer Portal

 

  • В появившемся окне (Рисунок 15) выбрать подпункт «Certificates» и нажать
    кнопку для добавления нового сертификата.

Рисунок 15. Окно работы с сертификатами в Apple Developer Portal

  • Далее необходимо выбрать тип создаваемого сертификата. Для нового Приложения можно использовать единый сертификат и для версии Development и для Production. Для этого нужно выбрать пункт «Apple Push Notification service SSL (Sandbox & Production)» (Рисунок 16). В случае, если необходимо создать два отдельных сертификата Development и Production, то необходимо выбрать соответствующий пункт и выполнить все последующие действия для каждого сертификата отдельно. После выбора типа сертификата нажмите кнопку «Continue».

Рисунок 16. Добавление сертификата в Apple Developer Portal

 

  • На следующем шаге необходимо создать файл запроса подписи сертификата (CSR). Для того, чтобы создать CSR файл, запустите Приложение «Keychain Access»  («Связка ключей»). Затем перейдите в пункт меню «Связка ключей»->»Ассистент сертификации»->»Запросить сертификат у бюро сертификации…» (Рисунок 17).

Рисунок 17. Запрос сертификата у бюро сертификации

 

В появившемся окне необходимо ввести информацию о запрашиваемом сертификате, выбрать пункт «Сохранен на диске» и нажать на кнопку «Продолжить» (Рисунок 18).

Рисунок 18. Информация о запрашиваемом сертификате

 

Затем в появившемся окне указать имя и путь для сохранения полученного файла CSR (Рисунок 19).

Рисунок 19. Сохранение сертификата

 

После создание CSR файла, необходимо нажать на кнопку «Continue» и затем в появившемся окне выбрать созданный ранее CSR файл (Рисунок 20).

Рисунок 20. Выбор CSR файла

 

  • После выбора CSR файла необходимо его сохранить с помощью кнопки «Download» (Рисунок 21). После сохранения файла нажать кнопку Done.

Рисунок 21. Сохранение сертификата

 

 

  • После сохранения файла сертификата необходимо его добавить в связку ключей. Для этого нужно сделать двойной клик по сохраненному ранее файлу, после чего откроется окно добавления сертификата в связку ключей (Рисунок 22).

Рисунок 22. Добавление сертификата в связку ключей

 

  • Далее необходимо в открывшемся окне выделить две строки — строку с сертификатом и строку с ключом (Рисунок 23).

Рисунок 23. Работа с сертификатом в Связке ключей

 

  • Затем нажать правую кнопку мыши и нажать на кнопку «Экспортировать объектов:2…» (Рисунок 24).

Рисунок 24. Экспортирование объектов в Связке ключей

  • В появившемся окне выбрать имя для файла и нажать на кнопку «Сохранить» (Рисунок 25).

Рисунок 25. Работа с сертификатом в Связке ключей

 

Также при необходимости для дополнительной защиты экспортируемых объектов можно задать пароль (Рисунок 26).

Рисунок 26. Защита экспортируемых объектов

 

  • После этого необходимо открыть Terminal и прописать следующую команду:

openssl pkcs12 -in certificate.p12 -out certificate.pem -nodes –clcerts

В данной команде certificate.p12 — имя сохраненного файла сертификата *.p12, а вместо certificate.pem необходимо указать имя сгенерированного файла сертификата *.pem, который уже непосредственно будет использоваться в дальнейшем при настройке Пуш-уведомлений. В случае, если на предыдущем пункте был задан пароль для защиты экспортируемых объектов, то этот пароль необходимо ввести в терминале после соответствующего запроса пароля.

 

 

Генерирование и загрузка сертификатов для серверов пуш-уведомлений Google

При создании нового Приложения в системе необходимо указать ключ сервера и Sender ID для данного Приложения.  

Для получения ключа необходимо в консоли управления Firebase (https://console.firebase.google.com/) добавить проект с Приложением, для которого будет создан данный ключ. Для этого нажмите соответствующую кнопку на панели Firebase (Рисунок 27).

Рисунок 27. Панель Firebase

 

В появившемся окне (Рисунок 28) введите название для проекта и выберите регион. После ввода данных нажмите кнопку «Создать проект».

Рисунок 28. Создание проекта в Firebase

Далее нажмите кнопку «Продолжить» (Рисунок 29).

Рисунок 29. Создание проекта в Firebase

 

После создания проекта перейдите в настройки проекта. Для этого нажмите на кнопку в панели управления проектом (Рисунок 30).

Рисунок 30. Настройки проекта Firebase

 

 

В появившемся окне перейдите на вкладку «Cloud messaging». В данной вкладке (Рисунок 31) находится ключ сервера и идентификатор отправителя (Sender ID). Нажмите на кнопку «Копировать» () и вставьте полученные данные в настройках Приложения в пространстве Разработчика.

Рисунок 31.  Cloud Messaging

Описание Дашборда

Дашборд пространства Development (Рисунок 32) — рабочая панель с основной информацией о Приложении. Дашборд содержит следующую информацию:

  • Карточка Приложения;
  • Информацию об API Приложения;
  • iOS SDK — Контейнер для интеграции полного функционала платформы в готовые мобильные приложения разработанные для iOS устройств;
  • Android SDK- Контейнер для интеграции полного функционала платформы в готовые мобильные приложения разработанные для Android устройств;
  • Platform manual — документация по работе с платформой, инструкции к панели управления и личному кабинету, а так же информация о всех возможностях нашей платформы с детальным описанием по интеграции API и SDK.

Рисунок 32.  Дашборд пространства Development

Описание карточки Приложения

Карточка Приложения содержит основную информацию о текущем открытом Приложении (Рисунок 33):

  • Имя Приложения;
  • Client id, Client Secret —  уникальные идентификаторы Приложения;
  • Описание Приложения (Description);
  • Состояние сертификатов пуш-уведомлений (APNS development certificate, APNS production certificate);
  • Состояние Идентификаторов мобильных приложений Android и Apple (Apple bundle id, Google bundle id);
  • Дата последнего обновления.

Рисунок 33. Карточка Приложения

Описание понятий ClientID, ClientSecret Приложения

Идентификаторы ClientID и Client secret представляют собой уникальный код, предназначенный для получения токена доступа к API. Данные идентификаторы генерируется автоматически при создании нового Приложения.

 

Описание флагов доступности функционала пуш-уведомлений

Флаги доступности функционала пуш-уведомлений – это индикаторы, которые показывают, заполнены ли в настройках Приложения соответствующие ключи и идентификаторы APNS development certificate, APNS production certificate, Api key, Sender ID, Apple bundle id, Google bundle id (Рисунок 34).

Рисунок 34. Флаги доступности функционала пуш-уведомлений

Описание раздела редактирования карты Здания

Редактирование карты Здания осуществляется в разделе работы со Зданиями. Для того, чтобы открыть данный раздел нажмите на кнопку Buldings в Дашборде Пространства Разработчика (Рисунок 35). Откроется меню работы со Зданиями, в котором можно создать новое Здание, выбрать для работы либо редактировать существующие Здания.

Рисунок 35. Раздел Buildings в Дашборде

Описание диалогового окна создания/редактирования/удаления Здания

Для создание нового Здания нажмите на кнопку  в меню работы со Зданиями (Рисунок 36).

Рисунок 36. Создание нового Здания

Описание вкладки Main

  • В появившемся окне создания нового Здания (Рисунок 37) необходимо внести информацию о создаваемом Здании.

Рисунок 37. Вкладка Main

 

  • Вкладка Main содержит следующие пункты:
  • Владелец Здания (Owner);
  • Тип здания (Building type);
  • Настройки датчиков Beacon (Beacons settings) – в данном пункте указывается уникальный идентификатор в формате UUID, который используется для навигации в здании. Данный идентификатор прописывается к датчикам Beacon, расположенным в данном Здании;
  • Contribution —  это настройка соотношения типа навигации, который будет использоваться в Здании. Используется два типа навигации: фингерпринтинг или мультилатерация, в настройках выставляется значение от 0 до 1, где 0 – это навигация только с помощью фингерпринтинг, 1 — это навигация только с помощью мультилатерации;
  • Location – адрес Здания.

Описание диалогового окна выбора/создания Владельца Здания

В диалоговом окне выбора/создания Владельца Здания (Рисунок 38) необходимо выбрать одного из существующих в Приложении Владельца Здания, либо добавить нового.

Рисунок 38. Выбор/создание Владельца Здания

 

Для добавления нового Владельца Здания нажмите на кнопку . В появившемся окне (Рисунок 39) и введите необходимые данные:

  • Категорию Владельца (Category) – выберите один из существующих типов категорий Владельцев Зданий или добавьте новую категорию Владельца Здания (см. п. 1.5.3.1.1.1.1).
  • Описание и адрес;
  • Тэги;
  • Контакты Владельца;

 

Рисунок 39. Создание Владельца Здания

Описание диалогового окна выбора/создания Категории к которой принадлежит Владелец Здания

В соответствующем поле необходимо выбрать либо одну из существующих Категорий или с помощью кнопки  добавить новую Категорию Владельца Здания (Рисунок 40).

Рисунок 40. Выбор Категории Владельца Здания

 

  • После нажатии на кнопки добавления новой Категории появится окно
    (Рисунок 41), в котором необходимо ввести имя новой Категории, а затем в соответствующем поле выбрать один из существующих Типов Категорий, либо добавить новый Тип Категории.

Рисунок 41. Выбор типа Категории Владельца Здания

Описание диалогового окна выбора/создания Типа Категории к которой принадлежит Владелец Здания

Для выбора Типа Категории, к которой принадлежит Владелец Здания, нажмите в соответствующем поле, после нажатия на которое появится диалоговое окно с существующими Типами Категорий. Также с помощью кнопки   можно добавить новый Тип Категории (Рисунок 42). После нажатия на данную кнопку откроется окно (Рисунок 43), в котором нужно ввести имя нового Типа Категории и нажать на кнопку Create.

Рисунок 42. Выбор типа Категории Владельца Здания

Рисунок 43. Создание Типа Категории Владельца Здания

Описание диалогового окна выбора/создания Типа Здания

Для того чтобы выбрать Тип Здания, необходимо нажать курсором в соответствующее поле, в котором откроется диалоговое окно выбора одного из существующих Типов Зданий (Рисунок 44). Также можно создать новый Тип Здания, для этого необходимо нажать на кнопку , затем в появившемся окне (Рисунок 45) ввести имя нового Типа Здания и после этого нажать на кнопку Create.

Рисунок 44. Диалоговое окно выбора/создания Типа Здания

Рисунок 45. Создание нового Типа Здания

Описание вкладки About

  • На вкладке About (Рисунок 46) представлена следующая информация о здании:
  • Descriptions – описание Здания;
  • Office hours – часы работы Здания;
  • Parking – информация о маршруте к парковке Здания;
  • Route – информация о маршруте к Зданию;
  • Custom tag – метка Здания (метка Разработчика, позволяющая связать какую-либо информацию Разработчика со Зданием).

Рисунок 46. Вкладка About

Описание вкладки Contacts

  • Вкладка Contacts (Рисунок 47) содержит основную контактную информацию о здании:
  • Phone – номер телефона Здания;
  • Email – адрес электронной почты Здания;
  • Website – вебсайт Здания;
  • Facebook – страница Здания в социальной сети Facebook;
  • Vkontakte – страница Здания в социальной сети Vkontalte;

Рисунок 47. Вкладка Contacts

Описание вкладки Calibration

На вкладке Calibration (Рисунок 48) отображается положение Здания на карте. Его необходимо откалибровать с помощью следующих настроек:

  • Longtitude – долгота Здания;
  • Latitude – широта Здания;
  • Angle – угол относительно Северного магнитного полюса;
  • Size – размер карты Здания в пикселях;
  • Width – ширина карты Здания в пикселях;
  • Height – высота карты Здания в пикселях;
  • Area – общая площадь Здания;
  • Scale —  масштаб Здания, пикселей на метр.

Рисунок 48. Вкладка Calibration

Описание функционала Редактора

Для того, чтобы открыть Редактор, необходимо перейти на вкладку Buildings. Затем, в появившемся справа списке доступных Зданий, с помощью кнопки  развернуть выпадающий список Здания для редактирования (Рисунок 49) и нажать на кнопку Edit floors ().

Рисунок 48. Список Зданий

 

В случае, если этажи Здания еще не были созданы, необходимо добавить новый этаж в Здание для редактирования. Для этого нажмите на выпадающее меню “Floor” Редактора (Рисунок 49) и нажмите “Create floor”.

 

Рисунок 49. Меню Редактора

 

В появившемся окне создания Этажей (Рисунок 50) введите необходимые данные и нажмите на кнопку Create.

Рисунок 50. Добавление нового Этажа

Описание главного меню

После создания нового Этажа откроется основное окно Редактора (Рисунок 51).  В главном меню Редактора (Menu) можно выбрать три диалоговых окна:

  • Canvas – редактирование Канвы;
  • Background image – редактирование изображения заднего плана;
  • Building color scheme – редактирование цветовой схемы Здания;

Рисунок 51. Окно Редактора

Описание диалогового окна Canvas

В диалоговом окне Canvas (Рисунок 52) устанавливаются настройки канвы соответствующего Здания. В данном диалоговом окне задаются следующие параметры:

  • Width — ширина в пикселях;
  • Height — высота в пикселях;
  • Scale — масштаб в пикселях на метр.

Рисунок 52. Диалоговое окно Canvas

Описание диалогового окна Background image

В диалоговом окне Backgound image (Рисунок 53) устанавливается изображение, которое будет использовано на заднем фоне Здания. Для того, чтобы выбрать изображение, нажмите на поле со значком . Затем в открывшемся диалоговом окне выберите файл с изображением, которое будет использовано как задний фон Здания. Для сохранения выбранного изображения нажмите на кнопку Save.

 

Рисунок 53. Диалоговое окно Background image

Описание диалогового окна Building color scheme

В диалоговом окне Building color scheme (Рисунок 54) настраивается цветовая схема для элементов Зданий, которые используются в графическом поле. Для различных элементов Зданий в системе изначально заданы определённые цвета, которые можно в дальнейшем изменить.

 

Рисунок 54. Диалоговое окно Background image

 

Для изменения цветовой схемы элемента нажмите на круглый значок в строке с элементом (), после чего откроется окно редактирования цветовой схемы (Рисунок 55). После выбора цвета из палитры, на который вы хотите изменить цвет данного элемента, нажмите на кнопку   Select. После внесения всех изменений в цветовую схему всех элементов, нажмите на кнопку Save.

 

Рисунок 55. Окно редактирования цветовой схемы элементов

Описание пункта меню View

В пункте меню View (Рисунок 56) устанавливаются настройки отображения элементов в графическом поле. Если установлен флаг ««, то данный элемент отображается на экране. Для того чтобы изменить видимость элемента, необходимо на него нажать, после чего флаг видимости напротив данного элемента станет пустым, и все элементы данного типа станут невидимыми.

Рисунок 56. Пункт меню View

 

С помощью настройки Grid scale (Рисунок 57) устанавливается масштаб сетки, которая отображается в графическом поле.

Рисунок 57.  Настройка масштаба сетки

Описание выпадающего меню создания/выбора/редактирования Этажей

С помощью выпадающего меню создания/выбора/редактирования Этажей
(Рисунок 58) выполняется настройка этажей Здания, также можно создать новой Этаж, открыть меню работы с уже созданными этажами Здания. Также в данном окне можно выбирать для работы ранее созданные Этажи Здания.

Рисунок 58.  Окно работы с этажами Здания

 

Для создания нового Этажа нажмите на кнопку Create floors. Создание нового этажа описано в пункте п. 1.5.3.2.  Для редактирования ранее созданных этажей нажмите на кнопку Manage floors. Откроется окно со списком доступных для редактирования этажей (Рисунок 59). Также в данном окне можно создать новый этаж с помощью кнопки ,а также удалить этаж с помощью кнопки .

Рисунок 59.  Редактирование этажей

 

Для редактирования этажа нажмите на кнопку в строке с этажом. В появившемся окне (Рисунок 60) есть возможность изменить имя этажа и изменить флаг его активности «Is active».

Рисунок 60.  Редактирование этажа

Описание инструмента Floor и его настроек в правой Панели Редактирования

С помощью инструмента Floor можно отрисовать объекты, которые непосредственно находятся на Этаже (Рисунок 61). Для создания элемента на графическом поле необходимо нарисовать соответстующий объект. Любые объекты отрисовываются с помощью двойного нажатия на левую кнопку мыши — с каждым нажатием ставится точка, от которой начинаются границы объекта. Для того, чтобы завершить рисование, необходимо привести курсором линию в начальную точку и опять выполнить двойной клик.  В правой Панели Редактирования можно изменить положение созданного объекта по осям координат х и у. Также внизу правой Панели Редактирования отображается список всех элементов типа Floor.

Рисунок 61.  Инструмент Floor

Описание инструмента Walls и его настроек в правой Панели Редактирования

Инструмент Walls позволяет рисовать и далее редактировать Стены на Этаже. Объеты Walls создаются аналогично любым другим объектам с помощью двойных кликов мышью в графическом поле (Рисунок 62). В правой Панели Редактирования можно изменить положение созданного объекта по осям координат х и у.  Также внизу правой Панели Редактирования отображается список всех элементов типа Walls.

 

Рисунок 62.  Инструмент Walls

Описание инструмента Rooms и его настроек в правой Панели Редактирования

Инструмент Rooms позволяет работать с уже созданными ранее комнатами, либо отрисовать новые комнаты на созданном ранее Этаже (Рисунок 63). Объеты Rooms создаются аналогично любым другим объектам с помощью двойных кликов мышью в графическом поле. В правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у, задать имя Комнаты и выбрать Владельца Комнаты из списка или добавить нового Владельца. Также внизу правой Панели Редактирования отображается список всех элементов типа Rooms.

Рисунок 63.  Инструмент Rooms

Описание инструмента Beacons и его настроек в правой Панели Редактирования

Инструмент Beacons позволяет работать с уже созданными ранее навигационным датчиками Beacon, либо отрисовать новые датчики () на созданном ранее Этаже (Рисунок 64). Объекты Beacons создаются аналогично любым другим объектам с помощью двойных кликов мышью в графическом поле. В правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у, выбрать модель Beacon’a из списка или добавить новую модель с помощью кнопки .  Также внизу правой Панели Редактирования отображается список всех элементов типа Beacons.

Рисунок 64.  Инструмент Beacons

 

Для добавления нового Beacon необходимо в появившемся окне ввести все данные нового датчика и нажать на кнопку Create (Рисунок 65).

Рисунок 65.  Добавление нового Beacon

Описание инструмента Devices и его настроек в правой Панели Редактирования

Инструмент Devices позволяет работать с уже созданными ранее Устройствами, либо отрисовать новые Устройства () на созданном ранее Этаже (Рисунок 66). Для того, чтобы создать объект Devices, необходимо сначала в соответствующем поле выбрать модель Устройства, после чего с помощью двойного клика мышью в графическом поле разместить его. Также можно добавить новое устройство с помощью кнопки . В правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у, загрузить конфигурационные файлы данного Устройства (INAP.json и INBLE.json), скопировать токен Устройства.  Также внизу правой Панели Редактирования отображается список всех элементов типа Devices.

Рисунок 66.  Инструмент Devices

Описание инструмента Cells и его настроек в правой Панели Редактирования

Инструмент Cells позволяет работать с точками считывания радиосигналов (в основном сигналов от датчиков Beacon). Точки измерений () можно создавать только в приложении InTool (App Store, Google Play) для мобильных устройств. Также внизу правой Панели Редактирования отображается список всех элементов типа Cells (Рисунок 67).

Рисунок 67.  Инструмент Cells

Описание инструмента AR Points и его настроек в правой Панели Редактирования

Инструмент AR Points позволяет работать с точками дополненной реальности. Можно добавить новые AR Points() на  Этаже (Рисунок 68), либо выбрать существующие. Для того, чтобы добавить объект AR Point, необходимо сначала в соответствующем поле выбрать маркер для данной точки (описание создания маркеров см. п.1.5.3.5.1), после чего с помощью двойного клика мышью в графическом поле разместить его. В правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у, также внизу правой Панели Редактирования отображается список всех элементов типа AR Points.

Рисунок 68.  Инструмент AR Points

Описание инструмента Media Points и его настроек в правой Панели Редактирования

Инструмент Media Points позволяет работать с точками, при приближении к которым у Пользователя будет воспроизводиться заданный медиа-ресурс. Можно добавить новые Media Points на Этаже (Рисунок 69), либо выбрать для настройки существующие. Для того, чтобы добавить объект Media Point (), необходимо сначала в соответствующем поле выбрать медиа-ресурс который будет воспроизводиться, после чего с помощью двойного клика мышью в графическом поле разместить его. Также необходимо задать радиус действия данной Media Point, и установить флаг активности. В правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у, также внизу правой Панели Редактирования отображается список всех элементов типа Media Points.

Рисунок 69.  Инструмент Media Points

  • Несколько Медиа Точек можно объединить в виртуальный Тур. Для этого нажмите на объект Media Point левой кнопкой мыши. Затем выберите для данного объекта Тур, к которому данная Точка будет относиться (Рисунок 70). Затем необходимо указать порядковый номер данной Медиа Точки в Туре. Все эти действия необходимо выполнить для каждой Медиа Точки.

Рисунок 70.  Инструмент Media Points

Описание инструмента Panorama Points и его настроек в правой Панели Редактирования

Инструмент Panorama Points позволяет работать с точками Здания, с помощью которых можно увидеть панораму места, где стоит данная Точка. Можно добавить новые Panorama Points на Этаже (Рисунок 71), либо выбрать для настройки существующие. Для того, чтобы добавить объект Panorama Point () необходимо разместить его с помощью двойного клика мышью в графическом поле. Для редактирования настроек объекта Panorama Point, нажать на него левой кнопкой мыши. После чего в правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у, выбрать изображение, которое будет использовано в качестве панорамы для выбранного объекта Panorama Point, из списка или добавить новое изображение с помощью кнопки (Рисунок 72).  Также внизу правой Панели Редактирования отображается список всех элементов типа Panorama Points.

Рисунок 71.  Инструмент Panorama Points

Рисунок 72. Добавление элемента Panorama Points

 

В появившемся окне создания нового объекта Panorama Point (Рисунок 73) необходимо задать его название, а также выбрать изображение, которое будет использовано в качестве Панорамы. Для того, чтобы выбрать изображение, нажмите на белое поле в середине окна, после чего появится диалоговое окно выбора изображения.

Рисунок 73. Создание нового элемента Panorama Points

Описание инструмента Infomat Points и его настроек в правой Панели Редактирования

Инструмент Infomat Points позволяет работать с точками в Здания, на которых расположены информационные терминалы. Можно добавить новые объекты Infomat Points на Этаже (Рисунок 74), либо выбрать для настройки существующие. Для того, чтобы добавить объект Infomat Point () необходимо разместить его с помощью двойного клика мышью в графическом поле. Для редактирования настроек объекта Infomat Point, нажать на него левой кнопкой мыши. После чего в правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у, выбрать медиа-ресурс из списка для данного Инфомата или добавить новый медиа-ресурс с помощью кнопки . Также внизу правой Панели Редактирования отображается список всех элементов типа Infomat Points.

Рисунок 74.  Инструмент Graph Points

Описание инструмента Graph Points и его настроек в правой Панели Редактирования

Инструмент Graph Points позволяет работать с точками в Зданиях, с помощью которых можно проложить маршрут следования Клиента. Далее между данными точками строятся элементы Graph Edges, указывающие направление движения. Можно добавить новые объекты Graph Points на Этаже (Рисунок 75), либо выбрать для настройки существующие. Для того, чтобы добавить объект Graph Points () необходимо разместить его с помощью двойного клика мышью в графическом поле. Для редактирования настроек объекта Graph Points, нажать на него левой кнопкой мыши. После чего в правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у.  Также внизу правой Панели Редактирования отображается список всех элементов типа Graph Points.

Рисунок 75.  Инструмент Graph Points

Описание инструмента Graph Edges и его настроек в правой Панели Редактирования

Инструмент Graph Edges предназначен для работать с точками Graph Points в Зданиях, с помощью которых можно проложить маршрут следования Клиента. Между данными точками Graph Points строятся элементы Graph Edges, указывающие направление движения. Можно добавить новые объекты Graph Points на Этаже (Рисунок 76), либо выбрать для настройки существующие. Для того, чтобы добавить объект Graph Edge необходимо с помощью двойного клика мышью в графическом поле выбрать точки Graph Points, между которыми будет создан данный вектор Graph Edge. Для редактирования настроек объекта Graph Edge, нажать на него левой кнопкой мыши. После чего в правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у, в диалоговом окне задать направление движения Пользователя (forward, backward, duplex). Также внизу правой Панели Редактирования отображается список всех элементов типа Graph Edge.

Рисунок 76.  Инструмент Graph Edges

Описание инструмента Icons и его настроек в правой Панели Редактирования

Инструмент Icons позволяет работать с различными иконками, используемыми на схеме Здания. Для того, чтобы добавить объект AR Point, необходимо сначала в соответствующем поле выбрать из палитры необходимую иконку (описание создания Иконок см. п.1.5.3.3.7), после чего с помощью двойного клика мышью в графическом поле разместить его (Рисунок 77). В правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у, также внизу правой Панели Редактирования отображается список всех элементов типа AR Points.

Рисунок 77.  Инструмент Icons

Описание инструмента Room Labels и его настроек в правой Панели Редактирования

Инструмент Room Labels позволяет работать с текстовыми метками для элементов Rooms, используемыми на схеме Здания (Рисунок 78). Для того, чтобы открыть настройки элемента Room Label, необходимо выбрать на схеме элемент Rooms и кликнуть на него левой кнопкой мыши. В правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у, изменить ширину и высоту данного элемента, повернуть его на заданный угол, выбрать цвет, а также установить флаг Text box (рамка текста). Также внизу правой Панели Редактирования отображается список всех элементов типа Room Label.

Рисунок 78.  Инструмент Text

Описание инструмента Background Image и его настроек в правой Панели Редактирования

Инструмент Background Image предназначен для работы с изображением, которое используется в качестве заднего плана Этажа на схеме Здания. Для выбора нового изображения для элемента Background Image нажмите на кнопку “Select background image” (Рисунок 79).

Рисунок 79.  Инструмент Background Image

 

После чего в появившемся диалоговом окне (Рисунок 80) нажмите на поле со значком , и в появившемся окне выберите изображение, которое будет использовано в качестве фона. Далее для сохранения изменений нажмите на кнопку Save. После чего в правой Панели Редактирований можно изменить положение созданного объекта по осям координат х и у, установить прозрачность данного изображения в процентах.

Рисунок 80.  Изменение изображения для Background Image

Описание панели Objects

Панель Objects (Рисунок 81) предназначено для редактирования и настройки созданных ранее объектов на схеме Здания. Объекты сгруппированы в соответствии со своими типами. Для редактирования какого-либо Элемента необходимо выбрать его из списка, и после нажатия на него левой кнопкой мыши, он станет активным на схеме Здания и доступным для редактирования.

Рисунок 81. Панель Objects

Описание раздела Summary

Раздел Summary (Рисунок 82) – это представление всех настраиваемых Объектов для текущего Здания в табличном виде. В данном разделе можно выбрать необходимую категорию Объекта, затем выбрать необходимый Объект и отредактировать. Также в данном разделе можно создавать новые Объекты.

Рисунок 82. Раздел Summary

Описание пункта создания/редактирования/удаления Buildings

В разделе Buildings (Рисунок 83) представлены все созданные Здания для текущего Приложения. С помощью кнопки можно создать новое Здание (описание создания нового Здания см. п.1.5.3.1). Для редактирования одного из Зданий выберите его из списка и нажмите на кнопку . С помощью кнопки можно удалить выбранное Здание. Также в данном подменю представлено поле для поиска Зданий текущего Приложения.

Рисунок 83. Раздел Buildings

Описание пункта создания/редактирования/удаления Building types

В разделе Buildings types (Рисунок 84) представлены все созданные Типы Зданий для текущего Приложения. С помощью кнопки можно создать новое Здание (описание создания нового Здания см. п.1.5.3.1.1.2). Для редактирования одного из Типов Зданий выберите его из списка и нажмите на кнопку. С помощью кнопки можно удалить выбранный Тип Здания. Также в данном подменю представлено поле для поиска Типов Зданий текущего Приложения.

Рисунок 84. Раздел Buildings types

Описание пункта создания/редактирования/удаления Owners

В разделе Owners (Рисунок 85) представлены все созданные Владельцы в Зданиях для текущего Приложения. С помощью кнопки можно создать нового Владельца (описание создания нового Здания см. п.1.5.3.1.1.1). Для редактирования одного из Владельцев Здания выберите его из списка и нажмите на кнопку. С помощью кнопки можно удалить выбранного Владельца Здания. Также в данном подменю представлено поле для поиска Владельцев Зданий текущего Приложения.

Рисунок 85. Раздел Owners

Описание пункта создания/редактирования/удаления Categories

В разделе Categories (Рисунок 86) представлены все созданные Категории Владельцев в Зданиях для текущего Приложения. С помощью кнопки можно создать новую Категорию Владельца (описание создания нового Здания см. п.1.5.3.1.1.1.1). Для редактирования одной из Категорий Владельцев Здания выберите её из списка и нажмите на кнопку. С помощью кнопки можно удалить выбранную Категорию Владельца Здания. Также в данном подменю представлено поле для поиска Категорий Владельцев Зданий текущего Приложения.

Рисунок 86. Раздел Categories

Описание пункта создания/редактирования/удаления Category types

В разделе Categories types (Рисунок 87) представлены все созданные Типы Категории Владельцев в Зданиях для текущего Приложения. С помощью кнопки можно создать новый Тип Категории Владельца (описание создания нового Здания см. п.1.5.3.1.1.1.2). Для редактирования одного из Типов Категорий Владельцев Здания выберите его из списка и нажмите на кнопку. С помощью кнопки можно удалить выбранный Тип Категории Владельца Здания. Также в данном подменю представлено поле для поиска Типов Категорий Владельцев Зданий текущего Приложения.

Рисунок 87. Раздел Category types

Описание пункта создания/редактирования/удаления Icon descriptions

В разделе Icon Descriptions (Рисунок 88) представлены все созданные описания для объектов Icon в Зданиях для текущего Приложения. Для создания нового объекта Icon Description нажмите кнопку , после чего в появившемся окне (Рисунок 89) введите Тип Иконки и новое Описание для неё, и нажмите на кнопку . Для редактирования одного из объектов Icon Description выберите его из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 90) внесите необходимые изменения и нажмите на кнопку . С помощью кнопки можно удалить выбранный объект Icon Description. Также в данном подменю представлено поле для поиска объектов Icon Description текущего Приложения.

Рисунок 88. Раздел Icon Description

Рисунок 89. Создание нового объекта Icon Description

Рисунок 90. Редактирование объекта Icon Description

Описание пункта создания/редактирования/удаления Icon types

В разделе Icon types (Рисунок 91) представлены все созданные Типы Иконок в Зданиях для текущего Приложения. Для создания нового объекта Icon type нажмите кнопку  , после чего в появившемся окне (Рисунок 92) введите имя для нового Типа Иконки, выберите цвет переднего и заднего плана Иконки, а также установите SVG путь для пола SVG путь для стен. Обязательное условие для SVG путей – они должны быть замкнуты. После этого нажмите на кнопку . Для редактирования одного из Типов Иконок выберите его из списка и нажмите на кнопку . С помощью кнопки можно удалить выбранный Тип Иконки. Также в данном подменю представлено поле для поиска Типов Иконок текущего Приложения.

Рисунок 91. Раздел Icon types

Рисунок 92. Создание новой Иконки

Описание пункта создания/редактирования/удаления Beacons

В разделе Beacons (Рисунок 93) представлены все созданные описания для объектов Icon в Зданиях для текущего Приложения. С помощью кнопки можно создать новый объект Beacon (описание создания нового Beacon’a см. п.1.5.3.2.7). Для редактирования одного из объектов Beacons выберите его из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 94) внесите необходимые изменения (Имя, UUID, параметры датчика) и нажмите на кнопку . С помощью кнопки можно удалить выбранный объект Beacons. Также в данном подменю представлено поле для поиска объектов Beacons текущего Приложения.

Рисунок 93. Раздел Beacons

Рисунок 94. Редактирование объекта Beacon

Описание пункта создания/редактирования/удаления Beacon notifications

В разделе Beacon notifications (Рисунок 95) представлены все созданные уведомления датчиков Beacon в Зданиях для текущего Приложения. С помощью кнопки можно удалить выбранный объект Beacons notification. Также в данном подменю представлено поле для поиска объектов Beacons notification текущего Приложения.

Рисунок 95. Раздел Beacons notification

 

Для создания нового объекта Beacons notification нажмите кнопку , после чего в появившемся окне (Рисунок 96) введите следующие данные:

  • Заголовок уведомления;
  • Текст уведомления;
  • Здание, в котором расположен датчик;
  • Данные датчика Beacon (выбрать датчик из списка);
  • Выбрать Владельца Здания;
  • Заголовок уведомления при выходе из зоны действия датчика;
  • Текст уведомления при выходе из зоны действия датчика;

После ввода всех данных нажмите на кнопку .

Рисунок 96. Создание объекта Beacons notification

Для редактирования одного из объектов Beacons notification выберите его из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 97) внесите необходимые изменения и нажмите на кнопку .

Рисунок 97. Редактирование объекта Beacons notification

Описание пункта создания/редактирования/удаления Local notifications

В разделе Local notifications (Рисунок 98) представлены все созданные локальные уведомления Зданиях для текущего Приложения. С помощью кнопки можно удалить выбранный объект Local notification. Также в данном подменю представлено поле для поиска объектов Local notification текущего Приложения.

Рисунок 98. Раздел Local notification

 

Для создания нового объекта Local notification нажмите кнопку , после чего в появившемся окне (Рисунок 99) введите следующие данные:

  • Заголовок уведомления;
  • Текст уведомления;

После ввода всех данных нажмите на кнопку .

Рисунок 99. Создание объекта Beacons notification

Для редактирования одного из объектов Local notification выберите его из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 100) внесите необходимые изменения и нажмите на кнопку .

Рисунок 100. Редактирование объекта Beacons notification

Описание пункта создания/редактирования/удаления Cells

В данном разделе представлены данные о радиоизмерениях для определенных ячеек Cells текущего Здания (Рисунок 101). Объекты Cells можно создавать только в приложении InTool (App Store, Google Play) для мобильных устройств. С помощью кнопки можно удалить выбранный объект Cells. Также в данном подменю представлено поле для поиска объектов Cells текущего Приложения.

Рисунок 101. Раздел Cells

 

Для выбранного объекта Cells можно посмотреть данные об измерениях для данной точки (Рисунок 102).

Рисунок 102. Измерения датчиков Beacons

Описание пункта создания/редактирования/удаления Devices

В разделе Devices (Рисунок 103) представлены все созданные Устройства, используемые в Зданиях для текущего Приложения. Для каждого Устройства представлен его токен. С помощью кнопки можно удалить выбранный объект Devices.
В данном подменю для каждого устройства можно скачать конфигурационные файл INAP.json и INABLE.json также в данном подменю представлено поле для поиска объектов Devices текущего Приложения.

Рисунок 103. Раздел Devices

 

Для создания нового объекта Devices нажмите кнопку , после чего в появившемся окне (Рисунок 104) введите имя Устройства и нажмите на кнопку .

Рисунок 104. Создание объекта Devices

 

Для редактирования одного из объектов Devices выберите его из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 105) внесите необходимые изменения и нажмите на кнопку .

Рисунок 105. Редактирование объекта Devices

Описание пункта создания/редактирования/удаления Tours

В разделе Tours представлены виртуальные Туры для текущего Здания
(Рисунок 106). Виртуальные Туры состоят из последовательности объектов Media Points (см. п.1.5.3.2.11), в каждом из которых задан медиа-ресурс, который будет воспроизводиться при приближении к данной Точке. С помощью кнопки можно удалить выбранный объект Tours.

Рисунок 106. Раздел Tours

 

Для создания нового объекта Tours нажмите кнопку , после чего в появившемся окне (Рисунок 107) введите следующие данные:

  • Название Тура;
  • Описание Тура;

После ввода всех данных нажмите на кнопку .

Рисунок 107. Создание объекта Tours

 

Для редактирования одного из объектов Tours выберите его из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 108) внесите необходимые изменения и нажмите на кнопку .

Рисунок 108. Редактирование объекта Tours

Описание пункта создания/редактирования/удаления Infomats

В разделе Infomats (Рисунок 109) представлены все созданные Инфоматы в Зданиях для текущего Приложения. С помощью кнопки   можно добавить новый Инфомат. Для редактирования одного из Инфоматов выберите его из списка и нажмите на кнопку . С помощью кнопки можно удалить выбранный Инфомат. Также в данном подменю представлено поле для поиска Инфоматов для текущего Здания.

Рисунок 109. Раздел Infomats

Описание раздела Dumps

Раздел Dumps представляет собой архив базы данных текущего Приложения (Рисунок 110), в котором сохраняются все объекты из раздела Summary текущего Приложения. Для сохранения одного из ранее созданных Дампов базы данных нажмите на кнопку «Download» в строке с ним. Для создания нового Дампа нажмите на кнопку после чего в появившемся окне нажмите на кнопку «Create».

Рисунок 110. Раздел Dumps

Описание раздела Markers

Раздел Markers (Рисунок 111) содержит в себе Маркеры, используемые для объектов дополненной реальности AR Points. С помощью кнопки можно удалить выбранный Инфомат. Также в данном подменю представлено поле для поиска Инфоматов для текущего Здания.

Рисунок 111. Раздел Markers

Описание диалогового окна создания/редактирования/удаления маркеров для функционала дополненной реальности

Для создания нового Маркера нажмите на кнопку , после чего в появившемся окне (Рисунок 112) необходимо указать следующую информацию:

  • Имя Маркера;
  • Изображение Маркера (для выбора изображения нажмите на белое поле и в появившемся окне выберите необходимое изображение);
  • Video URL — ссылку на видеофайл, который будет использоваться в Маркере для объекта AR Points;
  • Asset — медиа-ресурс, используемый в Маркере для объекта AR Points;

Рисунок 112. Создание объекта Markers

 

Для редактирования одного из Маркеров выберите его из списка и нажмите на кнопку . В появившемся окне (Рисунок 113) внесите изменения в необходимые данные Маркера и нажмите на кнопку «Save».

Рисунок 113. Редактирование объекта Markers

Описание раздела создания/редактирования/удаления медиа-контента (Media Assets)

В разделе Media Assets (Рисунок 114) представлены файлы, используемые в качестве медиа-контента в объектах Media Points. С помощью кнопки можно удалить выбранный объект Media Assetss. Также в данном подменю представлено поле для поиска файлов медиако-контента для текущего Приложения.  

Рисунок 114. Раздел Media Assets

 

Для создания нового объекта Media Assets , после чего в появившемся окне (Рисунок 115) необходимо указать следующую информацию:

  • Title —   название объекта Media Assets;
  • Description — описание объекта Media Assets;
  • Media content — файл с медиаконтентом для объекта Media Assets;

Рисунок 115. Создание объекта Media Assets

Для редактирования одного из объектов Media Assets выберите его из списка и нажмите на кнопку . В появившемся окне (Рисунок 116) внесите изменения в необходимые данные и нажмите на кнопку «Save».

Рисунок 116. Редактирование объекта Media Assets

Описание пункта создания/редактирования/удаления Приложения

Создание нового Приложения описано в пункте 1.5.1. Для редактирования текущего Приложения нажмите на кнопку (Settings), и в появившемся окне внесите необходимые изменения в Приложение. После внесения изменений нажмите на кнопку .

 

Пространство Маркетолога

Пространство Маркетолога предназначено для аналитики статитической информации о посещении Зданий, для настройки пуш-уведомлений, новостей и других маркетинговых инструментов.

 

Выбор существующего Приложения(Application)

Для выбора Приложения нажмите на вкладку Applications  (Рисунок 117) в левом верхнем углу Дашборда, и откройте необходимое Приложение.

Рисунок 117. Выбор существующего Приложения

Описание Дашборда

Дашборд пространства Marketing содержит в себе основную маркетинговую и статистическую информацию информацию о Приложении (Рисунок 118).

Рисунок 118. Дашборд Пространства Marketing

Описание карточки Приложения

Карточка Приложения содержит основную информацию о текущем открытом Приложении (Рисунок 119):

  • Имя Приложения;
  • Описание Приложения (Description);
  • Состояние сертификатов пуш-уведомлений (APNS development certificate, APNS production certificate);
  • Состояние Идентификаторов мобильных приложений Android и Apple (Apple bundle id, Google bundle id);
  • Дата последнего обновления.

Рисунок 119. Карточка приложения

Описание флагов доступности функционала пуш-уведомлений

Флаги доступности функционала пуш-уведомлений – это индикаторы, которые показывают, заполнены ли в настройках Приложения соответствующие ключи и идентификаторы APNS development certificate, APNS production certificate, Api key, Sender ID, Apple bundle id, Google bundle id (Рисунок 120).

Рисунок 120. Флаги доступности функционала пуш-уведомлений

Описание раздела просмотра Треков посетителей в режиме real-time

Для перехода в раздел Треков посетителей нажмите в Дашборде на вкладку Buildings. После этого в появившемся окне (Рисунок 121) откройте Здание, в котором хотите выполнить Трекинг посетителей и нажмите на кнопку (Tracking).

Рисунок 121. Вкладка Buildings

 

После этого откроется карта Здания с real-time  Треком посетителей (Рисунок122). В меню Трекинга также можно переключаться между этажами Здания.

Рисунок 122. Real-time Трекинг посещения Здания

Описание раздела просмотра статистики посещений Здания

Для того, чтобы открыть статистику посещения Здания, нажмите в панели меню соответствующую кнопку (). После нажатия откроется раздел просмотра статистики посещений Здания (Рисунок 123).

Рисунок 122. Просмотр статистики посещений Здания

Описание пункта выбора Здания

Для выбора Здания, статистику посещения которого необходимо открыть, нажмите на вкладку Buildings в панели инструментов (Рисунок 124) и выберите необходимое Здание.

Рисунок 124. Выбор Здания

Описание пункта выбора Этажа

Для выбора Этажа, статистику посещения которого необходимо открыть, нажмите на вкладку Floor(s) в панели инструментов (Рисунок 125) и выберите необходимый Этаж.

Рисунок 125. Выбор Этажа

Описание пункта Детализация

Для того, чтобы настроить временные параметры Детализации статистики, откройте вкладку Detailing hour в панели инструментов (Рисунок 126) и выберите временной интервал.

Рисунок 126. Выбор настроек Детализации статистики

 

Описание пункта выбора периода времени

Для того, чтобы настроить период времени, статистику за который необходимо посмотреть, откройте вкладку Period в панели инструментов (Рисунок 127) и установите необходимый период времени.

Рисунок 127. Выбор периода

Описание графика Visits

График Visits (Рисунок 128) показывает график посещений Здания в выбранный период времени. В данном графике можно выбрать вывод данных статистики по данным с датчиком Beacon, либо с Wi-Fi роутеров.

Рисунок 128. График посещений

Описание карточки Total

Карточка Total показывает обобщенные статистические данные по посещению выбранного Здания (Рисунок 129). В данной карточке отображается число уникальных посещений, диаграмму пользователей в соответствии с полом, диаграмму количества зарегистрированных пользователей среди посетителей, возрастную диаграмму.

Рисунок 129. Диаграмма данных

Описание карточки Summary

Карточка Summary показывает статистику посещений по Этажам (Рисунок 130).

Рисунок 130.  Карточка Summary

Описание раздела просмотра тепловой карты посещений Здания

Для того, чтобы открыть раздел просмотра тепловой карты посещений Здания, нажмите в панели меню соответствующую кнопку (). После нажатия откроется данный раздел (Рисунок 131).

Рисунок 131.  Раздел Heatmaps

Описание пункта выбора Здания

Для выбора Здания, статистику посещения которого необходимо открыть, нажмите на вкладку Buildings в панели инструментов (Рисунок 132) и выберите необходимое Здание.

Рисунок 132. Выбор Здания

Описание пункта выбора Этажа

Для выбора Этажа, статистику посещения которого необходимо открыть, нажмите на вкладку Floor(s) в панели инструментов (Рисунок 133) и выберите необходимый Этаж.

Рисунок 133. Выбор Этажа

Описание пункта выбора типа данных, по которым подсчитывается статистика (Trackpoints, ProbeRequests)

Для выбора типа данных, по которым подсчитывается статистика, нажмите на вкладку Data type(s) в панели инструментов (Рисунок 134) и выберите необходимый тип данных — Trackpoints или Wi-Fi.

Рисунок 134. Выбор типа данных, по которым подсчитывается статистика

Описание пункта выбора Radius

Для выбора радиуса действия устройств, по которым подсчитывается статистика, нажмите на вкладку Radius в панели инструментов (Рисунок 135) и выберите необходимый Радиус.

Рисунок 135. Выбор радиуса действия устройств, по которым подсчитывается статистика

Описание пункта выбора периода времени

Для того, чтобы настроить период времени, статистику за который необходимо посмотреть, откройте вкладку Period в панели инструментов (Рисунок 136) и установите необходимый период времени.

Рисунок 136. Выбор периода

Описание раздела Пуш-уведомления (Push notifications)

Для того, чтобы открыть раздел пуш-уведомлений, нажмите в панели меню соответствующую кнопку (). После нажатия откроется данный раздел (Рисунок 137).

Рисунок 137. Раздел настройки Пуш-уведомлений

Описание диалогового окна создания/редактирования задания на пуш-уведомления

Для создания нового задания на Пуш-уведомления нажмите кнопку , после чего в появившемся окне (Рисунок 138) введите следующие данные:

  • Имя нового задания;
  • Сообщение Пуш-уведомления;
  • Операционную систему, на которой будет использоваться данное Пуш-уведомление (Android или iOS);
  • Стадию разрабатываемого программного обеспечения для iOS (development или production).

На вкладке SHEDULE необходимо указать расписание для создаваемого Пуш-уведомления (Рисунок 139). После ввода всех данных нажмите на кнопку .

Рисунок 138. Создание задания на Пуш-уведомления

Рисунок 139. Расписание Пуш-уведомления

 

Описание окна со списком выполненных пуш-уведомлений

Для того, чтоб открыть статистику выполнения задания на  Пуш-уведомлений, нажмите на соответствующее Пуш-уведомление из списка левой кнопкой мыши, и затем выберите пункт «History». После этого откроется список выполненных Пуш-уведомлений для выбранного задания (Рисунок 140).

Рисунок 140. Расписание Пуш-уведомления

Описание раздела События

Для того, чтобы открыть раздел Событий, нажмите в панели меню соответствующую кнопку (). После нажатия откроется данный раздел (Рисунок 141). В разделе События представлены события трёх типов:

  • События Владельцев (Owners events);
  • События Зданий (Buildings events);
  • События Помещений (Rooms events).

Рисунок 141. Раздел События

Описание пункта создания/редактирования/удаления Owners events

Для создания события Owner Event выберите вкладку Раздела Событий «Owners events» и нажмите кнопку , после чего в появившемся окне (Рисунок 142) введите следующие данные:

  • Title — название События;
  • Description — описание События;
  • Owner — Владелец, к которому будет добавлено данное Событие.

Рисунок 142. Создание нового Owner Event

 

Для редактирования одного событий Owner Event, выберите его из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 143) внесите необходимые изменения и нажмите на кнопку .

Рисунок 143. Редактирование события Owner Event

Описание пункта создания/редактирования/удаления Building events

Для создания события Building Event выберите вкладку Раздела Событий «Building events» и нажмите кнопку  , после чего в появившемся окне (Рисунок 144) введите следующие данные:

  • Title — название События;
  • Description — описание События;
  • Building — Здание, к которому будет добавлено данное Событие.

Рисунок 144. Редактирование события Building Event

Для редактирования одного событий Building Event, выберите его из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 145) внесите необходимые изменения и нажмите на кнопку .

Рисунок 145. Редактирование события Building Event

Описание пункта создания/редактирования/удаления Room events

Для создания события Rooms Event выберите вкладку Раздела Событий «Rooms events» и нажмите кнопку , после чего в появившемся окне (Рисунок 146) введите следующие данные:

  • Title — название События;
  • Description — описание События;
  • Building — Здание, в котором находится данное Помещение;
  • Room — Помещение, к которому будет добавлено данное Событие;
  • Is active — флаг активности События.

Рисунок 146. Редактирование события Rooms Event

Для редактирования одного событий Rooms Event, выберите его из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 147) внесите необходимые изменения и нажмите на кнопку .

Рисунок 147. Редактирование события Rooms Event

Описание раздела Новости

Для того, чтобы открыть раздел Новости, нажмите в панели меню соответствующую кнопку (). После нажатия откроется данный раздел (Рисунок 148). В разделе Новости представлены события трёх типов:

  • Новости Владельцев (Owners news);
  • Новости Зданий (Buildings news);
  • Новости Помещений (Rooms news).

Рисунок 148. Раздел Новости

Описание пункта создания/редактирования/удаления Owner news

Для создания Новости Owner News выберите вкладку Раздела Новости «Owners news» и нажмите кнопку , после чего в появившемся окне (Рисунок 149) введите следующие данные:

  • Title — название События;
  • Description — описание События;
  • Owner — Владелец, к которому будет добавлено данное Событие.

Рисунок 149. Создание нового Owner News

 

Для редактирования Новости Owner News, выберите данную Новость из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 150) внесите необходимые изменения и нажмите на кнопку .

Рисунок 150. Редактирование события Owner News

Описание пункта создания/редактирования/удаления Building news

Для создания создания новости Building News выберите вкладку Раздела Новости «Building news» и нажмите кнопку , после чего в появившемся окне
(Рисунок 151) введите следующие данные:

  • Title — название События;
  • Description — описание События;
  • Building — Здание, для которого будет добавлена Новость.

Рисунок 151. Создание Новости Building News

 

Для редактирования Новости Building News, выберите её из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 152) внесите необходимые изменения и нажмите на кнопку .

Рисунок 152. Редактирование события Owner News

Описание пункта создания/редактирования/удаления Room news

Для создания Новости Rooms news  выберите вкладку Раздела Новости «Rooms news» и нажмите кнопку , после чего в появившемся окне (Рисунок 153) введите следующие данные:

  • Title — название События;
  • Description — описание События;
  • Building — Здание, в котором размещается Помещение;
  • Owner — Владелец, к которому будет добавлено данное Событие.

Рисунок 153. Создание Новости Rooms news

 

Для редактирования Новости Rooms news, выберите её из списка и нажмите на кнопку . После чего в появившемся окне (Рисунок 154) внесите необходимые изменения и нажмите на кнопку.

Рисунок 154. Редактирование Новости Rooms news